思科路由器配置接口桥接


一、前言

我们都知道,三层交换机的物理接口既能工作在二层模式,也能工作在三层模式。

那么路由器的物理接口能否工作在二层模式呢?当然可以!

我们可以通过在路由器上设置一个桥接组,然后将物理接口绑定到该桥接组来实现。

一个桥接组可以理解为交换机上的一个 VLAN,绑定到相同桥接组的物理接口处于同一广播域中。

每个桥接组也可配置对应的 BVI(桥接虚拟接口)来实现三层转发。BVI 和三层交换机的 SVI 作用基本相同。


二、网络拓扑图及说明

如图,四台 VPC 连接到了同一台路由器上。VPC1 与 VPC2 处在 192.168.1.0/24 网段内,VPC3 与 VPC4 处在 192.168.2.0/24 网段内。

各接口及网段的关系如上图所示。下面将在路由器上配置两个桥接组以及对应的 BVI 来实现四台 VPC 的互访。


三、配置方法

3.1 全局设置桥接模式为 IRB

Router(config)#bridge irb

说明
• IRB 的全称为集成路由转发,该模式允许桥接接口的流量参与三层转发。

3.2 设置桥接组使用的协议

% 使用 IEEE 802.1 系列协议作为二层协议
Router(config)#bridge 1 protocol ieee 
Router(config)#bridge 2 protocol ieee

% 使用 IP 作为三层协议
Router(config)#bridge 1 route ip
Router(config)#bridge 2 route ip

3.3 将接口绑定到桥接组中

说明
• 在把接口绑定到桥接组之前,最好把接口的 IP 地址删掉以防止地址冲突。

Router(config)#interface range ethernet 0/0-1
Router(config-if-range)#no ip address
Router(config-if-range)#bridge-group 1  % 将 ethernet 0/0、ethernet 0/1 绑定到桥接组 1 中
Router(config-if-range)#no shutdown
Router(config-if-range)#exit
Router(config)#interface range ethernet 0/2-3
Router(config-if-range)#no ip address
Router(config-if-range)#bridge-group 2  % 将 ethernet 0/2、ethernet 0/3 绑定到桥接组 1 中
Router(config-if-range)#no shutdown
Router(config-if-range)#exit

3.4 配置桥接组对应的 BVI

% 配置桥接组 1 对应的 BVI
Router(config)#interface BVI 1
Router(config-if)#ip address 192.168.1.253 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
% 配置桥接组 2 对应的 BVI
Router(config)#interface BVI 2
Router(config-if)#ip address 192.168.2.253 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit

四、验证结果

下面通过 VPC1 ping VPC2 以及 VPC3 ping VPC4 来检查二层的连通性;通过 VPC2 ping VPC3 以及 VPC4 ping VPC1 来检查三层的连通性。

4.1 二层连通性

VPC1 ping VPC2

VPC1> ping 192.168.1.2
84 bytes from 192.168.1.2 icmp_seq=1 ttl=64 time=0.671 ms
84 bytes from 192.168.1.2 icmp_seq=2 ttl=64 time=0.684 ms
84 bytes from 192.168.1.2 icmp_seq=3 ttl=64 time=1.070 ms
84 bytes from 192.168.1.2 icmp_seq=4 ttl=64 time=1.067 ms
84 bytes from 192.168.1.2 icmp_seq=5 ttl=64 time=1.291 ms

VPC3 ping VPC4

VPC3> ping 192.168.2.2
84 bytes from 192.168.2.2 icmp_seq=1 ttl=64 time=1.144 ms
84 bytes from 192.168.2.2 icmp_seq=2 ttl=64 time=0.929 ms
84 bytes from 192.168.2.2 icmp_seq=3 ttl=64 time=0.695 ms
84 bytes from 192.168.2.2 icmp_seq=4 ttl=64 time=0.798 ms
84 bytes from 192.168.2.2 icmp_seq=5 ttl=64 time=0.439 ms

可以看出,二层连通性已经没问题了。

4.2 三层连通性

VPC2 ping VPC3

VPC2> ping 192.168.2.1
84 bytes from 192.168.2.1 icmp_seq=1 ttl=63 time=1.727 ms
84 bytes from 192.168.2.1 icmp_seq=2 ttl=63 time=1.168 ms
84 bytes from 192.168.2.1 icmp_seq=3 ttl=63 time=1.130 ms
84 bytes from 192.168.2.1 icmp_seq=4 ttl=63 time=0.808 ms
84 bytes from 192.168.2.1 icmp_seq=5 ttl=63 time=1.250 ms

VPC4 ping VPC1

VPC4> ping 192.168.1.1
84 bytes from 192.168.1.1 icmp_seq=1 ttl=63 time=2.753 ms
84 bytes from 192.168.1.1 icmp_seq=2 ttl=63 time=1.171 ms
84 bytes from 192.168.1.1 icmp_seq=3 ttl=63 time=1.120 ms
84 bytes from 192.168.1.1 icmp_seq=4 ttl=63 time=0.573 ms
84 bytes from 192.168.1.1 icmp_seq=5 ttl=63 time=0.795 ms

很好,全网都已经通了!

分享到:

发表评论

电子邮件地址不会被公开。