在思科路由器上配置 PPPoE 拨号上网


一、前言

PPPoE 是目前家庭宽带的主流接入方式。

看完本文之后,您或许就可以把思科的企业级路由器当作家里的主路由器了,嘻嘻~


二、拓扑图 & 需求

家里刚拉了一条宽带,ISP 要求使用 PPPoE 进行接入。

PPPoE 的用户名是 cisco,密码是 123

现在要用一台思科的路由器作为主路由器让家里的设备都能上网。

e0/0 接口连接外网,e0/1 接口连接内网。

内网的网段是 192.168.1.0/24,路由器的内网 IP 是 192.168.1.1/24


三、操作步骤

(路由器已经恢复出厂设置)

3.1 进入配置模式

Router>enable
Router#configure terminal

3.2 配置物理接口

e0/0 接口

Router(config)#interface ethernet 0/0
Router(config-if)#no ip address         % 物理接口不要配置 IP 地址
Router(config-if)#pppoe-client dial-pool-number 1   % 作为 PPPoE 客户端并加入 1 号拨号池
Router(config-if)#no shutdown 
Router(config-if)#exit

e0/1 接口

Router(config)#interface ethernet 0/1
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#ip nat inside                         % 设为 NAT 内部接口
Router(config-if)#no shutdown 
Router(config-if)#exit

3.3 配置 PPPoE 接口

用于拨号的 dialer0 虚拟接口

Router(config)#interface dialer 0
Router(config-if)#encapsulation ppp         % 使用 PPP 协议封装
Router(config-if)#ip address negotiated     % 使用 PPP 协议自动获取 IP 地址
Router(config-if)#ppp ipcp route default    % 自动设置默认路由
Router(config-if)#dialer pool 1             % 加入 1 号拨号池
Router(config-if)#ppp chap hostname cisco               % 设置 CHAP 身份验证使用的用户名
Router(config-if)#ppp chap password 123                 % 设置 CHAP 身份验证使用的密码
Router(config-if)#ppp pap sent-username cisco password 123    % 设置 PAP 身份验证使用的用户名和密码
Router(config-if)#ip nat outside                        % 设为 NAT 外部接口
Router(config-if)#exit

3.4 配置 DHCP 服务器

Router(config)#ip dhcp pool lan     % 创建一个名为 lan 的 DHCP 地址池
Router(dhcp-config)#network 192.168.1.0 255.255.255.0   % 设置地址池的网段
Router(dhcp-config)#default-router 192.168.1.1          % 设置默认网关
Router(dhcp-config)#dns-server 8.8.8.8 8.8.4.4          % 设置 DNS 服务器
Router(dhcp-config)#exit

3.5 配置 NAT

Router(config)#access-list 1 permit 192.168.1.0 0.0.0.255   % 设置一条包含内网网段的 ACL 规则
Router(config)#ip nat inside source list 1 interface dialer 0 overload  % 把来自内网网段访问外网的流量进行 PAT 转换

3.6 保存设置 & 退出

Router(config)#exit
Router#write 
Router#exit

四、检查结果

4.1 检查 PPPoE 接口

Router#show ip interface brief | section Dialer0

运行结果:

Dialer0                    192.168.18.103  YES IPCP   up                    up 

如果拨号接口有 IP 地址,且状态为 up,说明工作正常。

4.2 检查 DHCP 服务器

配置内网主机通过 DHCP 自动获取 IP。如果可以获取到 IP,说明 DHCP 服务器配置正确。

内网主机获取 IP 之后可以在路由器上检查下 DHCP 地址池的分配情况。

Router#show ip dhcp binding 

运行结果:

Bindings from all pools not associated with VRF:
IP address          Client-ID/          Lease expiration        Type
            Hardware address/
            User name
192.168.1.2         0150.0100.0200.00       May 28 2018 04:11 PM    Automatic

4.3 检查能否上网

在内网主机上随便打开一个网页。如果可以打开,说明 NAT 以及路由配置正确。

打开网页之后可以在路由器检查下 NAT 的工作情况。

Router#show ip nat translations 

运行结果:

Pro Inside global      Inside local       Outside local      Outside global
tcp 192.168.18.103:49215 192.168.1.2:49215 117.18.237.29:80  117.18.237.29:80
tcp 192.168.18.103:49232 192.168.1.2:49232 52.37.11.39:443   52.37.11.39:443
tcp 192.168.18.103:49233 192.168.1.2:49233 163.177.131.52:80 163.177.131.52:80
tcp 192.168.18.103:49234 192.168.1.2:49234 163.177.131.52:443 163.177.131.52:443
tcp 192.168.18.103:49235 192.168.1.2:49235 202.108.23.152:443 202.108.23.152:443
tcp 192.168.18.103:49236 192.168.1.2:49236 163.177.131.52:80 163.177.131.52:80
tcp 192.168.18.103:49237 192.168.1.2:49237 163.177.131.52:80 163.177.131.52:80
tcp 192.168.18.103:49238 192.168.1.2:49238 163.177.131.52:80 163.177.131.52:80
tcp 192.168.18.103:49239 192.168.1.2:49239 163.177.131.52:80 163.177.131.52:80
...

发表评论

电子邮件地址不会被公开。