思科路由器帧中继及其动态路由的原理与配置


一、前言

帧中继是点到多点广域网、多点到多点广域网的解决方案。

虽然它早已过时,但它所代表的轴辐型(Hub-Spoke)拓扑结构的 NBMA(非广播多路访问)网络还是非常值得学习一下的。

本文纯属个人学习经验分享。如有错误,请尽管提出,非常感谢!


二、认识帧中继

2.1 轴辐型拓扑结构

帧中继最常用的拓扑是轴辐型拓扑。

该拓扑一般由一个中心节点和若干分支节点组成。分支节点只能和中心节点通信,而它们之间是无法直接通信的。

如果分支节点之间需要相互通信,那就需要把中心路由器当作“跳板”。

拓扑结构如下图:

帧中继除了使用轴辐型拓扑之外,也可使用全网状(Full-Mesh)、半网状(Partial-Mesh)拓扑。

2.2 帧中继的一些特点

帧中继是一种以虚电路(两台 DTE 之间用来传输数据的虚拟连接)为基础的广域网技术,它由 X.25 协议演进而来。

帧中继工作在 OSI 参考模型的物理层与数据链路层上。

帧中继将两台终端设备(DTE)之间的一整条虚电路分为两部分。一部分为一台终端设备(DTE)到帧中继交换机(DCE)之间的虚电路,另一部分为另一台终端设备(DTE)到帧中继交换机(DCE)之间的虚电路。

帧中继使用 DLCI(数据链路连接 ID)作为二层地址来标识终端设备(DTE)到帧中继交换机(DCE)之间的虚电路。

帧中继交换机(DCE)通过映射两部分虚电路来完成完整虚电路的建立,实现终端设备(DTE)之间的相互通信。

帧中继交换机(DCE)和终端设备(DTE)之间使用 LMI(本地管理接口)信令进行连接管理和保持。

说明
⦁ LMI 有三种标准:Cisco 专有标准、ANSI 公有标准、Q933A 公有标准。
⦁ DLCI 仅仅用于标识终端设备(DTE)到帧中继交换机(DCE)之间的这部分虚电路,且不支持复用。因此两台互相通信的终端设备(DTE)各自的 DLCI 必须不同。

和以太网一样,帧中继也可使用 ARP(准确来说是 Inverse ARP)协议来实现二层地址(DLCI)与三层地址(IP 地址)的映射。

说明
⦁ 如果使用轴辐型拓扑,且各分支节点之间要相互通信的话,在默认情况下是需要配置 DLCI 与 IP 地址映射的(也可以通过 OSPF 自动通告的接口路由条目来解决,后面会说到)。

2.3 帧中继的标准工作流程

① 路由器连接好帧中继交换机,上电。
② 路由器向帧中继交换机发送状态请求,请求建立虚电路连接。
③ 帧中继交换机发送状态相应,告诉路由器使用哪个虚电路及 DLCI。
④ 路由器发送一个 ARP 报文(可以理解为 GARP)介绍自己。
⑤ 对端路由器添加一个 IP <--> DLCI 的映射,同时也介绍自己。
⑥ 路由器每隔 60 秒发送一个 ARP(可以理解为 GARP)报文介绍自己。
⑦ 路由器定期发送 LMI 信息保持虚电路的激活。

2.4 让帧中继支持广播和组播

帧中继本身是不支持广播和组播报文的,因为它是一种 NBMA(非广播多路访问)网络。

在默认情况下,路由器在帧中继接口上收到广播或者组播报文都会直接被丢弃。

不过有两种方法可以实现广播报文和组播报文的转发。两种方法各有各的优缺点。

2.4.1 配置点对点子接口

我们可以将帧中继接口划分为多个逻辑的点对点子接口。而每个点对点子接口对应着一条虚电路。

虽然这样做可以完美支持广播和组播报文,但是需要为每一条点对点逻辑链路分配一个网段,全网的广播域的数量增加了。

2.4.2 手动指定广播目的地址(伪广播)

此方法需要手动创建 DLCI 与 IP 地址的映射。我们可以将映射的 IP 地址设为广播目的地址。

当路由器在帧中继接口上收到广播或者组播报文时,直接将广播或者组播报文转发给指定的广播目的地址。

这种方法虽然可以在全网状的拓扑上完美工作,但是一旦涉及到需要“跳板”的通信(比如轴辐型拓扑分支节点间通信),一般的广播报文就肯定过不去了。因为经过“跳板”就相当于经过一台路由器,而一般的广播报文是不支持跨越路由器传输的(TTL 等于 1)。至于组播报文,如果有相关的组播路由条目再加上报文本身 TTL 大于 1 的话,就还能过去。

2.5 在帧中继网络中配置动态路由

2.5.1 RIP & EIGRP

需要使用上面 2.4 中的任意一种让帧中继支持广播和组播的方法。

使用 2.4.1 方法无需额外的配置。

使用 2.4.2 方法且网络为轴辐型或半网状拓扑结构时,需要在中心路由器的帧中继接口上关闭水平分割功能。

水平分割指的是:路由器从一个接口中学到的路由表项不能再通过这个接口发送出去。

水平分割可以用来防止路由环路。

因为中心路由器只有一个接口连接着帧中继交换机。如果不关闭水平分割的话,那么中心路由器将无法向外发送从其他路由器中学习到的网段。

2.5.2 OSPF

OSPF 默认将帧中继接口设为非广播(non-broadcast)类型,所有邻居都必须手工指定。

如果不想手工指定的话,那就需要使用上面 2.4 中任意一种让帧中继支持广播和组播的方法。

使用 2.4.1 方法无需额外的配置。OSPF 默认将帧中继点对点子接口设为点对点(point-to-point)类型。

使用 2.4.2 方法时,需要将帧中继接口设为点对多点(point-to-multipoint)类型,这样就能确保帧中继网络中所有路由器的 LSDB 同步。

也可将帧中继接口设为广播(broadcast)类型。但在轴辐型或半网状拓扑结构的网络中,需要将中心路由器的帧中继端口的 OSPF 优先级调高,确保中心路由器是指定路由器(DR)。


三、网络拓扑图及分析

有 R1、R2、R3、R4 四个路由器以及一个帧中继交换机,路由器各接口地址以及交换机虚电路映射关系如上图所示。

可以看出,这是一个轴辐型拓扑。R1 作为中心路由器,R2、R3、R4 作为分支路由器。

接下来将分别使用 RIP 以及 OSPF 动态路由协议来实现四个路由器之间各网段的互通(不使用虚拟子接口)。


四、接口的配置

4.1 R1

enable

configure terminal

interface Loopback0
ip address 1.1.1.1 255.255.255.255
exit

interface Serial8/0
ip address 100.0.0.1 255.255.255.0
encapsulation frame-relay                   %接口使用帧中继封装
frame-relay map ip 100.0.0.2 100 broadcast  %手动将 100.0.0.2 映射到 DLCI 100 中,并将收到的广播帧发送到该电路中
frame-relay map ip 100.0.0.3 101 broadcast  %手动将 100.0.0.3 映射到 DLCI 101 中,并将收到的广播帧发送到该电路中
frame-relay map ip 100.0.0.4 102 broadcast  %手动将 100.0.0.4 映射到 DLCI 102 中,并将收到的广播帧发送到该电路中
no shutdown
exit

4.2 R2

enable

configure terminal

interface Loopback0
ip address 2.2.2.2 255.255.255.255
exit

interface Serial8/0
ip address 100.0.0.2 255.255.255.0
encapsulation frame-relay
frame-relay map ip 100.0.0.4 200 broadcast
frame-relay map ip 100.0.0.3 200 broadcast
frame-relay map ip 100.0.0.1 200 broadcast
no shutdown
exit

4.3 R3

enable

configure terminal

interface Loopback0
ip address 3.3.3.3 255.255.255.255
exit

interface Serial8/0
ip address 100.0.0.3 255.255.255.0
encapsulation frame-relay
frame-relay map ip 100.0.0.4 201 broadcast
frame-relay map ip 100.0.0.2 201 broadcast
frame-relay map ip 100.0.0.1 201 broadcast
no shutdown
exit

4.4 R4

enable

configure terminal

interface Loopback0
ip address 4.4.4.4 255.255.255.255
exit

interface Serial8/0
ip address 100.0.0.4 255.255.255.0
encapsulation frame-relay
frame-relay map ip 100.0.0.3 202 broadcast
frame-relay map ip 100.0.0.2 202 broadcast
frame-relay map ip 100.0.0.1 202 broadcast
no shutdown
exit

4.5 测试与分析

4.5.1 连通性测试

下面将使用 ping 测试 R2 与 R1、R3、R4 的连通性。

R2 -> R1

ping 100.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 9/10/12 ms

R2 -> R3

ping 100.0.0.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.0.0.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/21/23 ms

R2 -> R4

ping 100.0.0.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.0.0.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 18/20/22 ms

从上面的结果可看出,各个路由器的帧中继接口可以互访了。

4.5.2 广播包传播的分析

下面分别用 R1、R3 ping 255.255.255.255。

说明
⦁ 在 ping 之前可在全局配置模式下执行 no ip domain-lookup 来关闭 DNS 反向解析,节省宝贵的时间。

R1 -> 255.255.255.255

ping 255.255.255.255
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 255.255.255.255, timeout is 2 seconds:

Reply to request 0 from 100.0.0.2, 44 ms
Reply to request 0 from 100.0.0.3, 44 ms
Reply to request 0 from 100.0.0.4, 44 ms
Reply to request 1 from 100.0.0.4, 72 ms
Reply to request 1 from 100.0.0.2, 72 ms
Reply to request 1 from 100.0.0.3, 72 ms
Reply to request 2 from 100.0.0.2, 11 ms
Reply to request 2 from 100.0.0.4, 11 ms
Reply to request 2 from 100.0.0.3, 11 ms
Reply to request 3 from 100.0.0.3, 36 ms
Reply to request 3 from 100.0.0.4, 36 ms
Reply to request 3 from 100.0.0.2, 36 ms
Reply to request 4 from 100.0.0.3, 53 ms
Reply to request 4 from 100.0.0.2, 53 ms
Reply to request 4 from 100.0.0.4, 53 ms

R3 -> 255.255.255.255

ping 255.255.255.255
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 255.255.255.255, timeout is 2 seconds:

Reply to request 0 from 100.0.0.1, 27 ms
Reply to request 0 from 100.0.0.1, 27 ms
Reply to request 0 from 100.0.0.1, 27 ms
Reply to request 1 from 100.0.0.1, 65 ms
Reply to request 1 from 100.0.0.1, 65 ms
Reply to request 1 from 100.0.0.1, 65 ms
Reply to request 2 from 100.0.0.1, 81 ms
Reply to request 2 from 100.0.0.1, 81 ms
Reply to request 2 from 100.0.0.1, 81 ms
Reply to request 3 from 100.0.0.1, 16 ms
Reply to request 3 from 100.0.0.1, 16 ms
Reply to request 3 from 100.0.0.1, 16 ms
Reply to request 4 from 100.0.0.1, 55 ms
Reply to request 4 from 100.0.0.1, 55 ms
Reply to request 4 from 100.0.0.1, 55 ms

从上面结果可以看出:在轴辐型拓扑结构的网络中,中心节点发送的广播报文可以到达所有分支节点,但分支节点发送的广播报文只能到达中心节点。

这是因为分支节点之间需要相互通信的时候需要把中心路由器当作“跳板”,而经过这个“跳板”就相当于经过一个路由器,一般的广播帧都过不去了。

至于组播帧,在没有设置组播路由的情况下也是过不去的。

说明
⦁ 有很多组播帧的 TTL 也只有 1(如 OSPF),这样的话即使设置组播路由也是过不去的。除非修改 TTL 值。

下面我们在 R2 上 traceroute R1 和 R3 看看有什么区别。

R2 -> R1

traceroute 100.0.0.1
Type escape sequence to abort.
Tracing the route to 100.0.0.1
VRF info: (vrf in name/id, vrf out name/id)
  1 100.0.0.1 10 msec *  10 msec

R2 -> R3

traceroute 100.0.0.3
Type escape sequence to abort.
Tracing the route to 100.0.0.3
VRF info: (vrf in name/id, vrf out name/id)
  1 100.0.0.1 10 msec 11 msec 12 msec
  2 100.0.0.3 19 msec *  21 msec

很明显,R2 在访问 R3 的时候需要经过一台路由器转发。所以说“跳板”无法转发一般的广播帧。


五、RIP 的配置

5.1 R1

interface Serial8/0
no ip split-horizon     %在中心路由器上关闭水平分割
exit

router rip
version 2               %使用 RIPv2
network 1.1.1.1
network 100.0.0.0
no auto-summary         %关闭自动汇总
exit

5.2 R2

router rip
version 2
network 2.2.2.2
network 100.0.0.0
no auto-summary
exit

5.3 R3

router rip
version 2
network 3.3.3.3
network 100.0.0.0
no auto-summary
exit

5.4 R4

router rip
version 2
network 4.4.4.4
network 100.0.0.0
no auto-summary
exit

5.5 测试与分析

下面将检查所有路由器的 RIP 路由表,然后测试 R2 ping R4 环回接口。

5.5.1 R1

RIP 路由表

show ip route rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      2.0.0.0/32 is subnetted, 1 subnets
R        2.2.2.2 [120/1] via 100.0.0.2, 00:00:05, Serial8/0
      3.0.0.0/32 is subnetted, 1 subnets
R        3.3.3.3 [120/1] via 100.0.0.3, 00:00:08, Serial8/0
      4.0.0.0/32 is subnetted, 1 subnets
R        4.4.4.4 [120/1] via 100.0.0.4, 00:00:02, Serial8/0

5.5.2 R2

RIP 路由表

show ip route rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
R        1.1.1.1 [120/1] via 100.0.0.1, 00:00:14, Serial8/0
      3.0.0.0/32 is subnetted, 1 subnets
R        3.3.3.3 [120/2] via 100.0.0.3, 00:00:14, Serial8/0
      4.0.0.0/32 is subnetted, 1 subnets
R        4.4.4.4 [120/2] via 100.0.0.4, 00:00:14, Serial8/0

5.5.3 R3

RIP 路由表

show ip route rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
R        1.1.1.1 [120/1] via 100.0.0.1, 00:00:09, Serial8/0
      2.0.0.0/32 is subnetted, 1 subnets
R        2.2.2.2 [120/2] via 100.0.0.2, 00:00:09, Serial8/0
      4.0.0.0/32 is subnetted, 1 subnets
R        4.4.4.4 [120/2] via 100.0.0.4, 00:00:09, Serial8/0

5.5.4 R4

RIP 路由表

show ip route rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
R        1.1.1.1 [120/1] via 100.0.0.1, 00:00:12, Serial8/0
      2.0.0.0/32 is subnetted, 1 subnets
R        2.2.2.2 [120/2] via 100.0.0.2, 00:00:12, Serial8/0
      3.0.0.0/32 is subnetted, 1 subnets
R        3.3.3.3 [120/2] via 100.0.0.3, 00:00:12, Serial8/0

5.5.5 连通性测试

R2 -> R4

ping 4.4.4.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 19/20/21 ms

5.5.6 结果分析

所有路由器均已成功学习全网的路由表,全网可互联。


六、OSPF 的配置

说明
1. 由于在默认情况下,RIP 的管理距离(120)比 OSPF(110)要大,因此系统在 RIP 路由表项和 OSPF 路由表项共存的情况下会优先使用 OSPF 路由表项。
2. 以下步骤是基于前面的配置进行的。

6.1 R1

interface Serial8/0
ip ospf network point-to-multipoint   %指定帧中继接口为点到多点类型
exit

router ospf 1
network 1.1.1.1 0.0.0.0 area 0
network 100.0.0.0 0.0.0.255 area 0
exit

6.2 R2

interface Serial8/0
ip ospf network point-to-multipoint
exit

router ospf 1
network 2.2.2.2 0.0.0.0 area 0
network 100.0.0.0 0.0.0.255 area 0
exit

6.3 R3

interface Serial8/0
ip ospf network point-to-multipoint
exit

router ospf 1
network 3.3.3.3 0.0.0.0 area 0
network 100.0.0.0 0.0.0.255 area 0
exit

6.4 R4

interface Serial8/0
ip ospf network point-to-multipoint
exit

router ospf 1
network 4.4.4.4 0.0.0.0 area 0
network 100.0.0.0 0.0.0.255 area 0
exit

6.5 测试与分析

下面将检查所有路由器的 OSPF 路由表和邻居表,然后测试 R3 ping R4 环回接口。

6.5.1 R1

OSPF 路由表

show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      2.0.0.0/32 is subnetted, 1 subnets
O        2.2.2.2 [110/65] via 100.0.0.2, 00:00:26, Serial8/0
      3.0.0.0/32 is subnetted, 1 subnets
O        3.3.3.3 [110/65] via 100.0.0.3, 00:00:40, Serial8/0
      4.0.0.0/32 is subnetted, 1 subnets
O        4.4.4.4 [110/65] via 100.0.0.4, 00:00:26, Serial8/0
      100.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
O        100.0.0.2/32 [110/64] via 100.0.0.2, 00:00:26, Serial8/0
O        100.0.0.3/32 [110/64] via 100.0.0.3, 00:00:40, Serial8/0
O        100.0.0.4/32 [110/64] via 100.0.0.4, 00:00:26, Serial8/0

OSPF 邻居表

show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           0   FULL/  -        00:01:43    100.0.0.2       Serial8/0
4.4.4.4           0   FULL/  -        00:01:43    100.0.0.4       Serial8/0
3.3.3.3           0   FULL/  -        00:01:58    100.0.0.3       Serial8/0

6.5.2 R2

OSPF 路由表

show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
O        1.1.1.1 [110/65] via 100.0.0.1, 00:00:57, Serial8/0
      3.0.0.0/32 is subnetted, 1 subnets
O        3.3.3.3 [110/129] via 100.0.0.1, 00:00:57, Serial8/0
      4.0.0.0/32 is subnetted, 1 subnets
O        4.4.4.4 [110/129] via 100.0.0.1, 00:00:57, Serial8/0
      100.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
O        100.0.0.1/32 [110/64] via 100.0.0.1, 00:00:57, Serial8/0
O        100.0.0.3/32 [110/128] via 100.0.0.1, 00:00:57, Serial8/0
O        100.0.0.4/32 [110/128] via 100.0.0.1, 00:00:57, Serial8/0

OSPF 邻居表

show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           0   FULL/  -        00:01:40    100.0.0.1       Serial8/0

6.5.3 R3

OSPF 路由表

show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
O        1.1.1.1 [110/65] via 100.0.0.1, 00:01:27, Serial8/0
      2.0.0.0/32 is subnetted, 1 subnets
O        2.2.2.2 [110/129] via 100.0.0.1, 00:01:03, Serial8/0
      4.0.0.0/32 is subnetted, 1 subnets
O        4.4.4.4 [110/129] via 100.0.0.1, 00:01:03, Serial8/0
      100.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
O        100.0.0.1/32 [110/64] via 100.0.0.1, 00:01:27, Serial8/0
O        100.0.0.2/32 [110/128] via 100.0.0.1, 00:01:03, Serial8/0
O        100.0.0.4/32 [110/128] via 100.0.0.1, 00:01:03, Serial8/0

OSPF 邻居表

show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           0   FULL/  -        00:01:53    100.0.0.1       Serial8/0

6.5.4 R4

OSPF 路由表

show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
O        1.1.1.1 [110/65] via 100.0.0.1, 00:01:33, Serial8/0
      2.0.0.0/32 is subnetted, 1 subnets
O        2.2.2.2 [110/129] via 100.0.0.1, 00:01:23, Serial8/0
      3.0.0.0/32 is subnetted, 1 subnets
O        3.3.3.3 [110/129] via 100.0.0.1, 00:01:33, Serial8/0
      100.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
O        100.0.0.1/32 [110/64] via 100.0.0.1, 00:01:33, Serial8/0
O        100.0.0.2/32 [110/128] via 100.0.0.1, 00:01:23, Serial8/0
O        100.0.0.3/32 [110/128] via 100.0.0.1, 00:01:33, Serial8/0

OSPF 邻居表

show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           0   FULL/  -        00:01:40    100.0.0.1       Serial8/0

6.5.5 连通性测试

R3 -> R4

ping 4.4.4.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/20/21 ms

6.5.6 结果分析

所有路由器均已成功学习全网的路由表,全网可互联。

从邻居表可以看出:中心路由器 R1 可以和分支路由器 R2、R3、R4 建立邻居关系,但分支路由器只能和 R1 建立邻居关系。原因在 4.5.2 已经分析了,这里不再赘述。

还有一个细节,就是 OSPF 会在点对多点(point-to-multipoint)类型的接口下自动向外通告一条去往该接口 IP 的 /32 路由条目。利用 OSPF 这一特性,当使用轴辐型拓扑时,各分支节点之间如果需要通信就无需配置 DLCI 与 IP 地址的映射了。


七、参考文献

  1. 周昕编著;数据通信与网络技术(第 2 版);清华大学出版社;2014
  2. [美]约翰逊(Johnson,A.)著;思科系统公司译;思科网络技术学院教程. CCNA Exploration: 路由协议和概念;人民邮电出版社;2009.1
  3. [美]里德(Reid,A.)著;北京邮电大学思科网络技术学院译;思科网络技术学院教程. CCNA. 4,广域网技术;人民邮电出版社;2008.2
  4. Comprehensive Guide to Configuring and Troubleshooting Frame Relay – Cisco
  5. 帧中继常见问题 – Cisco
  6. Problems with Running OSPF in NBMA and Broadcast Mode over Frame Relay – Cisco

发表评论

电子邮件地址不会被公开。